Back to overview

Server/Map Outage 1/3/2025 15:30 CST

Jan 03 at 03:38pm CST
Affected services
Map
Minecraft Server
Alpha Minecraft Server

Resolved
Jan 06 at 10:07am CST

This issue is now resolved.

Created
Jan 03 at 03:38pm CST

Our main, alpha, and map servers are currently experiencing a minor outage as communicated by our vendor. We are monitoring this outage through their communication channels and will provide updates as they become available.